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1.  Introduction 
1.1  How to use this manual 
 
This manual is very comprehensive. You can read it from cover to cover or use it as a reference. 
 
Assumptions: 
 

• We assume that you have an intermediate Joomla Knowledge and experience.  
• All steps start by selecting Magazine from your Component menu list, if you’re not 

already there. We will then refer to the left menu navigation as “iJoomla Magazine.” 
• We use the standard command -> to symbolize moving to the next level on a menu. 
• Actions will be colored in Green and have a different font. Like this. 

 
1.2  What is iJoomla Magazine? 
 
IJoomla Magazine Component is a component for Joomla CMS (Content Management System) 
that allows website owners to publish an online magazine using existing content and templates. 
 
Before you can understand how to operate iJoomla Magazine, you will need to understand the 
basic principles that underlie the system. If you skip this section, you will probably have difficulties 
later. 
 
iJoomla Magazine helps you organize existing content into Magazines, Issues and Articles. You 
must already have at least one section, one category and one content item to get started. You will 
use the existing content item to populate your magazine issues. 
 
You will also be able to add, edit and remove magazines, issues and articles from iJoomla 
Magazine without affecting your Joomla content items. 
 
Your magazine can be used as a section of your site or as the main site feature. You can use it to 
replace your existing home page component (called “front page”) or use it in addition to other 
sections of the site. 
 
1.3  Structure 
 
Your magazine contain four levels: 
 

• Magazines are containers that hold one or more Issues. 
• Issues are containers that hold one or more Articles. 
• Articles make up your actual website content (the source of your articles is your existing 

content items). 
• Sub-articles can be added to your article page’s sidebar and, like articles, can be created 

from existing content items. 
 
For example, if you have a site about pets, you can choose to create a number of separate 
magazines, each dedicated to a different type of pet: Dog Magazine, Cat Magazine, Bird 
Magazine etc.. Inside each magazine, you can publish an issue monthly or weekly about related 
subjects. So each month, you could publish a new issue for the dogs magazine with articles 
about dogs. And each article could have a related sub-article. An article about dog adoption for 
example, could have a sub-article about how to find a great name for your dog. 
 
1.4  What you can do with iJoomla Magazine 
 



Although the name is iJoomla Magazine, this component, its modules and plugin can be used to 
easily manage any Joomla site for any purpose. Core Joomla is quite limited in its layout and 
style control. IJoomla helps you make the most of your Joomla site. 
 
Use it to: 
 

• Publish an online magazine; 
• Help organize your existing Joomla site in a much better way than is possible with core 

Joomla. 
 
1.5  Requirements 

1.5.1 Software 
 
IJoomla Magazine is not a stand-alone software. It requires Joomla! or Mambo Content 
Management Systems to work. 
 

• Compatible with  
o Joomla 1.x  
o  

In order for iJoomla Magazine to work properly, you need to have the following requirements: 
 

• Joomla Installed (sorry, we don't support Mambo with our newest version 2.0) 
• Safe mode  must be OFF 
• Magic quotes gpc must be ON 
• Short open tags must be ON 
• Ioncube installed or installable 

 
We've created a script that can help you determine if your site is compatible with our 
components. Please download it here. 
  
Please install it on the root of your site, and access it using your browser like this: 
 
http://www.yoursite.com/ijoomla_test.php 
 
Replace the "http://www.yoursite.com/" with your Joomla URL. 
 
As long as everything on the page is GREEN, you have no problem. It will look like the following 
example: 
 
http://www.ivegetarian.net/ijoomla_test.php 
 
If any of the items are RED, please open a support ticket and we will help you make your site 
compatible. 

1.5.2 Knowledge 
 
In order to start building your magazine, you will need the following: 
 

• Intermediate Joomla knowledge including installation of components/modules and 
creating items, publishing items etc. If you're just starting with Joomla, this may not be a 
good place to begin. Come back in a month or two when you're more comfortable with 
the Joomla software. 

• Basic image handling. To create a magazine with images you will need a graphics 
program and know how to create resize/crop images.  

http://www.ijoomla.com/option,com_remository/Itemid,0/func,fileinfo/id,64/
http://www.ijoomla.com/support/index.php


• You don't need to understand CSS but it helps. We provide you with 12 different style 
sheets that you can either use as is or modify. You will need basic CSS knowledge to 
modify the CSS code. 

 
1.6 Limitations 
 
Although iJoomla Magazine is a very powerful component, it had to be created as an integral part 
of Joomla, and core Joomla has its limitations. 
  

• The entire magazine and its magazines, issues and articles are considered as one entity. 
You cannot therefore assign different modules to different issues or articles. 
 

 
2. Getting Started 
 
2.1  Installing/un-installing/upgrading 

2.1.1 Installation 

2.1.1.1 First time installation: 
 
Unzip the zip file called iJoomlaMagazineV20.zip. 

 
Save the content on a folder of your choice on your computer.  

 
The zip file contains six sub-files and two text files: 

 
i com_magazine.zip 
ii mod_magazine_issues.zip 
iii mod_featured_article_article.zip 
iv mod_current_articles.zip 
v mod_upcoming_articles.zip 
vi mod_magazine_list .zip 
vii mod_author_list.zip 
viii mos_magazine.zip 
ix LICENSE.txt 
x README.txt  
xi  
 

Com_magazine.zip is the iJoomla component. The following seven files are component modules. 
The last zipped file is the iJoomla mambot. 
 
Note: Unless you plan to install iJoomla Magazine manually, you won’t need to unzip these zip 
files! Just follow the instructions below. 

2.1.1.2 Uploading the component 
 
On your admin interface, select Installers -> Components from the menu. 
Find and upload the zip file marked com_magazine.zip. 
 



 
 

2.1.1.3 Uploading the modules 
 
Select Installers -> Modules from the menu and upload the following modules one at a time: 
 

• mod_magazine_issues.zip 
• mod_featured_article.zip 
• mod_current_articles.zip 
• mod_upcoming_articles.zip 
• mod_magazine_list .zip 
• mod_author_list.zip 
•  

 

 
 
 
2.1.1.4 Uploading the Mambots 
 
Select Installers -> Mambots from the menu. 
Find and upload the mambot zip file, mos_magazine.zip  



 
 

 
 
Important: Publish the plugin. Select Mambot-> Site Mambots 
 

 
 
You’re done uploading iJoomla Magazine! 
 

2.1.1.5 Installation Problems: 
 
Most installation problems occur because the installer does not have all the necessary 
permissions.  
 
You will need the following permissions in order to install iJoomla Magazine successfully. No 
need to change anything if you are able to install the components/modules/plugin successfuly: 
 

• 777 on components/com_magazine/layouts and all the files in it 
• 777 on administrator/components/com_magazine/language and all the files in it 
• 777 on components/com_magazine/layouts/css and all the files in it 
• 777 on administrator/components/com_magazine/magazine.config.php 



 
 

o  
If you do not have these permissions, please contact your hosting service and ask them to help 
you or submit a support ticket here.

2.1.1.5 Manual Installation 
 

• Unzip the component, modules and mambot and save them on your computer.  
• Upload all files to a server directory of your choice. 
• Select Installers -> Components from the menu and choose Install from the directory 

option. Enter the full path of the place the magazine component was installed. 

2.1.2 Un-installing 

2.1.2.1 Uninstalling the component 
 

• Select Installers -> Components from the menu.  
• Check the radio button next to “Magazine” and click Uninstall. 

2.1.2.2 Uninstalling the modules 
 

• Select Installers -> Modules from the menu.; 
• Check the radio button next to “mod_magazine_list ” and click Uninstall. 
• Check the radio button next to “mod_current_articles” and click Uninstall; 
• Check the radio button next to “mod_magazine_issues” and click Uninstall; 
• Check the radio button next to “mod_featured_article” and click Uninstall; 
• Check the radio button next to “mod_upcoming_articless” and click Uninstall; 
• Check the radio button next to “mod_author_list.zip” and click Uninstall. 
• Check the radio button next to “mod_author_list.zip” and click Uninstall. 

 

2.1.2.3 Uninstalling the plugin 
 

• Select Installers -> Mambots from the menu; 
• Check the radio button next to “mos_magazine” and click Uninstall. 

 
 2.2  Upgrading  

 
When upgrading to a new version of iJoomla, none of your information will be lost except for the 
settings, which will need to be entered again. 
 

• Un-install iJoomla Magazine; 
• Re-install iJoomla Magazine.  

 
2.3 Upgrading from versions 1.x to 2.x 
 
Version 2.x includes a new magazine level. During installation therefore, you will be asked to click 
an upgrade link which will create one magazine to which all your existing issues will be added. If 
you forget to click on this link, you will simply need to create at least one magazine and assign all 
your current issues to it. 
 

http://www.ijoomla.com/support/index.php


2.4 Linking to iJoomla Magazine on the front end 
 

• Select iJoomla Magazine ->  Main Menu. 
• Click the New icon in the toolbar.  
• On the next page, select Component from the Components box. 
• You should now be on the Add Menu Item :: Component page. 
• Enter a name for the menu link (eg,Home or Magazine).  
• Select Magazine from the Component list box.  
• Click the Save icon in the toolbar. 

 

 
 

 



 
 
2.5  Making iJoomla your home page 
 
To make iJoomla Magazine your default home page, move it to the first position on the main 
menu. 
 

• Select iJoomla Magazine ->  Main Menu. 
• Use either the arrows in the reorder column or the numbers in the order column to move 

the magazine component to the first row.  

 
 
3. How to use iJoomla magazine 
3.1  How to access iJoomla Magazine 
 
To access the iJoomla Magazine on the admin interface, click Component on the top menu and 
select Magazine. (It’s marked by an M icon.) 
 



 
 
3.2  Navigation 
 
Unlike many other components, iJoomla Magazine uses a left navigation menu and a control 
panel, not a top navigation. You can easily navigate with either the control panel or the left menu. 
 
3.2.1  Control Panel 
 
When you access iJoomla Magazine on your admin interface, you will see a control panel with 
large icon. You can reach most of the component features with this menu. Whenever you’d like to 
reach this control panel, select iJoomla magazine from the component menu or if you’re already 
inside iJoomla Magazine, click on the top left menu link “iJoomla Magazine”. 
 
 

 



 
3.2.2  Left Menu 
 
The first time you access the iJoomla Magazine interface, the left menu will be closed and you 
will see only the top level items. Click on each to see the sub menu items or to reach the area of 
your choice. 
 
Click Close All to close all the menu items. Click Open All to open all the menu items and their 
sub-items. 
 

 
 
3.3  Saving 
 
Be sure to save every page you’ve changed in order to record the changes, as you should 
whenever you use Joomla. 
 
 
4. Features 
 
This section lists all the features of iJoomla Magazine and outlines what you can do with the 
component. Later we will explain each of the features in more detail. 
 
4.1 General Features 
 
iJoomla allows publishers to do all of the following: 
 

• Replace the current front page with any of your issues’ home pages and maintain better 
control over your home page layout; 

• Create an unlimited number of magazines; 
• Create an unlimited number of issues for each magazine; 
• Create an unlimited number of home pages using magazines and issues; 
• Organize existing content in a magazine format; 
• Add an unlimited number of existing content articles to each issue; 
• Make each magazine and issue about a different topic or the same general topic; 
• Give your home page any of the 12 layouts available in dozens of rows/columns 

combinations. 
 



4.2 Settings 

4.2.1 General 
 

• Choose to display a default magazine; 
• Choose to show “related articles” at the end of the current article; 
• Choose to show “more articles by this author” at the end of the current article. 
• Choose to show the “Powered by iJoomla Magazine” notice. 

4.2.2 CSS  
 

• Magazine style control 
o Control the style of the magazine name; 
o Control the style of the magazine description. 

• Issue style control 
o Control the style of the issue name; 
o Control the style of the issue description. 

• Quotes 
o Control the style of the quotes; 

• Sidebar 
o Control the style of the sidebar heading; 
o Control the style of the sidebar article title; 
o Control the style of the sidebar intro text; 
o Control the style of the sidebar box. 

• Author Mini Profile 
o Control the style of the author mini profile heading; 
o Control the style of the author mini profile text; 
o Control the style of the author mini profile box. 

• Vertical articles 
o Control the style of the vertical zone general title; 
o Control the style of the vertical article heading; 
o Control the style of the vertical article title; 
o Control the style of the vertical article intro text . 

• Horizontal articles 
o Control the style of the horizontal zone general title; 
o Control the style of the horizontal article heading; 
o Control the style of the horizontal article title; 
o Control the style of the horizontal article intro text. 

4.2.3 Separators 
 

• Choose the image to be used a separator between the vertical articles; 
• Choose the image to be used a separator between the horizontal articles. 

4.2.4 Language 
  

• Edit the language of both the back and front end; 
• Replace the current language file with your own or any of the available language files. 

 
 



4.3 Managing Content 

4.3.1 Content wizard 
 

• Add up to 10 magazines with one click; 
• Add up to 10 issues and choose the parent magazine for each with one click; 
• Add up to 10 articles, enter their headings, choose the parent magazine, issue and 

orientation with one click. 

4.3.2 Managing Magazines 
 

• Add new magazines; 
• Edit existing magazines; 
• Enter a title for the magazine; 
• Choose to hide or show magazine title;  
• Control the order of the magazines; 
• Choose a default issue for the magazine; 
• Enter a description of the magazine; 
• Publish/un-publish magazines; 
• Delete magazines; 
• Choose the access level of the magazine (public/registered/special); 
• Automatically publish/un-publish magazines by choosing start/finish date. 

 

4.3.3 Managing Issues 
 

• Add new issues; 
• Edit existing issues; 
• Determine the parent magazine for each issue; 
• Enter a title for the issue; 
• Choose to hide or show issue title; 
• Choose a featured article for each issue; 
• Choose the main article for each issue; 
• Delete issues; 
• Control the order of the issues; 
• Enter a description of each issue; 
• Choose a layout for each issue; 
• Choose a style for each issue; 
• Vertical Item Control 

o Choose the vertical zone heading for each issue; 
o Choose the amount of columns and rows for the vertical articles; 
o Choose to show simple text or HTML text on the vertical articles intro text on the 

home pages; 
o Limit the intro text length for vertical articles on the home pages. 

• Horizontal Item Control 
o Choose the horizontal zone heading for each issue; 
o Choose the number of columns and rows for the horizontal articles; 
o Choose to show simple text or HTML text on the horizontal articles intro text on 

the home pages; 
o Limit the intro text length for horizontal articles on the home pages; 
o Choose to show or hide banners between the horizontal articles. 

• Publish/un-publish issues; 
• Automatically publish/un-publish issues by choosing start/finish date; 



• Choose the access level of each issue (public/registered/special); 
• Choose the image for the main article; 
• Choose the position of the main image (left/center/right). 

4.3.4 Managing Articles 
 

• Add new articles from existing content articles; 
• Edit existing articles; 
• Enter a heading for each article; 
• Choose to hide or show article heading; 
• Choose the article orientation (vertical/horizontal); 
• Determine the parent magazine and issue for each article; 
• Determine the existing content item to be used as article; 
• Choose a URL to link to anything other than articles, such as component, external URLs, 

images, etc.; 
• Publish/un-publish articles; 
• Delete articles; 
• Control the order of the articles; 
• Choose a thumbnail for each article; 
• Choose the position of the home page thumbnail; 
• Choose parts of the text to be used as quotes. 

 
4.4 Authors 
 
 

• Display a list of all your Joomla existing authors; 
• Add new authors; 
• Delete authors; 
• Add a photo to each author; 
• Add a short and long bio to your author; 
• Add a website URL to each author; 
• Choose to show or hide author’s mini profile on article page; 
• Show author full profile with photo, bio and contact information; 
• Display a list of all your authors on the front end. 

 
4.5  Design (Layout & Style) 

4.5.1  Layout Manager 
 

• 12 layouts are available with iJoomla Magazine; 
• Add your own layouts; 
• Edit existing layouts; 
• Assign layouts to your issues. 

4.5.2  Style Manager 
 

• 12 style sheets are available with iJoomla Magazine; 
• Add your own style sheets; 
• Edit existing style sheets; 
• Assign style sheets to your issues. 

4.5.3  Magazine Newsletter 
 



• Choose the magazine and issue to send; 
• Create a template for the newsletter and preview the newsletter before sending; 
• Send a test email by choosing “super administrator” from the list; 
• Choose the group of users to which you’d like to send the magazine;  
• The email will look like your magazine, including images, styles and links to the articles;  
• Enter the subject of your newsletter and send the magazine in PDF format, including text 

to describe the PDF attachment. 
 
4.6  Modules 

4.6.1  Magazines 
 

• Displays a list of all your published magazines. 

4.6.2  Back Issues 
 

• Displays a list of the published issues for the magazine currently in view.. 

4.6.4  Current Articles 
 

• Displays all the articles in the default issue of the magazine currently in view. 

4.6.5  Featured Article 
 

• Displays the featured article for the issue currently in view. 

4.6.6  Authors 
 

• Displays a list of your authors. 

4.6.7  Upcoming Articles 
 

• Displays the titles of articles to be published in the next issue of this magazine.  
 
4.7  Plugin 
 

• Adds five extra features for your article page. 

4.7.1  Quotes 
 

• Adds as many quotes as you wish using existing text; 
• Places quotes anywhere on the page. 

4.7.2  Sidebar 
 

• Adds a sidebar to your article page; 
• Use existing content item as source; 
• Use sidebar to display ads and banners. 

4.7.3  Author Mini profile  
 

• Displays author’s mini profile on article page; 



• Choose to show or hide mini profile for each author; 
• Mini profile links to full profile page. 

4.7.4  Related Articles 
 

• Choose to show/hide related articles; 
• Choose the number of related articles to show. 

4.7.5  More articles by this author 
 

• Choose to show/hide “More articles by this author”; 
• Choose the number of articles to show. 

 
4.8  Easy Navigation 
 

• Main control panel; 
• Left side navigation for easy access; 
• Open or close all items. 
 

 
5. Managing Content 
 
Publishers can choose one of two methods to add content to each magazine: 
 

• Content wizard; 
• One-by-one. 

 
The content wizard is an ideal quick start for publishers who are just beginning to create a 
magazine. The wizard allows you to add multiple items at one time instead of individual items 
separately, whether you need to add magazine issues or articles. 
 
Having used the wizard to add your content quickly, you will then be able to open each item and 
edit it further (for example, by adding images or changing text). 
 
If your magazine has already been launched, you can use the One-By-One Method to add all the 
parameters without having to re-open each item. 
 
5.1 Content wizard 
 
Select iJoomla Magazine->Content-> Content Wizard. 
 
You will see three options: 
 

• Add Magazines;  
• Add Issues; 
• Add Articles. 

 
Note: you must have at least one magazine in order to add issues and at least one issue in order 
to add articles. 
 



 

5.1.1 Adding Magazines Using The Content Wizard 
 

• Check the radio box next to Add Magazines and click the Next button on the top right.  
• Enter a name for the magazine on one or more of the rows and click the Next button. 
• The magazines have now been created and are visible on the list of magazines. Open 

each magazine to configure it further. 

 



 

5.1.2 Adding Issues Using The Content Wizard 
 

• Check the radio box next to Add Issues and click the Next button on the top right.  
• Enter a name for the issue, choose the parent magazine on one or more of the rows and 

click the Next button. 
• The magazines have now been created and are visible on the list of issues. Open each 

issue to configure it further. 
 

 



 

5.1.3 Adding Articles 
 

• Check the radio box next to Add Articles and click the Next button on the top right.  
• Choose the article from the drop down menu, enter a heading, choose the orientation and 

the magazine/issue.   
• Click the Next button. 
• The articles have now been added to your magazines and are visible on the list of 

articles. Open each article to configure it further. 

 



 
 
Note: Entering a heading is mandatory. Rows without heading specified will not be added. 
Tip: Use the drop down filters to easily find the articles you wish to add. 
 
5.2 Adding Content Without The Wizard: The One-By-One Method 

• Select iJoomla Magazine -> Manage Content -> Magazines from the menu. 
• Click the New button. 
• On the General tab, enter the magazine title and choose to show or hide the name of the 

magazine.  
• Enter a description of the magazine. This description will show under the magazine name 

(if shown). 
• On the Publishing tab, choose whether or not to publish the magazine. Un-published 

magazines will not be displayed on the site or on the magazine module.  
• Choose the date to start and finish publishing the magazine. By default the starting date 

is today’s date and the finishing date is empty. (The magazine will continue to be 
published unless you enter a finishing date). 

• Choose the access level: public, registered or special. 
• Click Save. 

 
 
5.3 Adding Issues one-by one 
 
5.3.1 Adding Issues one-by one 
 

• Select IJoomla Magazine -> Manage Content -> Issues from the menu. 



• Click the New button. 
• On the General tab, choose a parent magazine and enter the issue title and name. 

Choose to show or hide the title. Once you have at least one article assigned to this 
issue, you will be able to choose a featured and main article.  

• Enter a description to be displayed under the issue title (if shown). 
• On the Design tab, choose a layout and style from the drop down menus and enter the 

horizontal and vertical zone general heading. Choose the number of rows/columns for 
each zone. 

• On the Publishing tab, choose whether or not to publish the issue. Un-published issues 
will not be displayed on the site or on the back issues module. To publish or un-publish 
this issue automatically, choose a starting and ending date. The default starting date is 
today and the default ending date is “Never”. 

• Choose the access level for this issue. 
• On the Image tab, choose the main image for this issue and the image position. 
• Click Save. 
 

 
5.4 Adding Articles Using The Content Wizard 
 
There are two aspects to managing your articles: 
 

• Adding content to your Joomla site; 
• Adding articles to your Magazine. 

5.4.1 Adding content to your Joomla site; 
 
iJoomla allows you to use existing content for your magazine. If you don’t yet have any content 
articles, you will first need to add some. If you already have content articles, please skip to the 
next section. 
 
How to add content articles to your Joomla site: 
 

• Create at least one section by selecting Content -> Sections -> New from the menu. 
• Enter a name for the section and press Save. 
• Create at least one category by selecting Content -> Categories -> New from the menu. 
• Enter a name for the category and press Save. 



• Add a content article by selecting Content -> All content articles -> New. 
• Enter the article and press Save. 
• Repeat until you have added all your content articles and continue placing content in 

sections and categories as needed. 

 
 

5.4.2 Adding articles to your Magazine 
 
Once content articles have been added to your Joomla site, they may be placed in  
your magazine: 
 

• Select IJoomla Magazine -> Manage Content -> Articles from the menu. 
• On the General tab, enter a heading to be displayed above the content item on the home 

page and choose whether or not to show the heading. 
• Select a vertical or horizontal orientation. 
• Choose the parent magazine for the article and the parent issue for the item. 
• Select the category. The page will refresh and show articles only in the selected 

category. 
• Choose an article from the drop down menu. If you’d like to link to an URL other than the 

article, enter the URL here. 
• Select the Publishing tab to publish or un-publish this item. 
• Select the Images tab to add a thumbnail images to your article. Highlight the home page 

image on the left list and click the >> button. 
• Once you have placed an image, it will be moved to the right-hand list. 
• To remove an image, highlight the image on the right list and click the << button. 
• Finally, select the position of the image (left/right/center) 
• Select the Sidebar tab to choose the source of the side bar of this article (optional). 

 
Note: The Home page thumbnail is usually a small photo. 
 



 
 
To add images to the article page itself, please open the content item as usual and use 
mosimage to place your images. Alternatively, you may select Manage Content -> Articles and 
click on the article title on the second column. This will open an edit page in a new window 
browser that will allow you to edit the article and add your images. 
 

 
 
5.5 Removing Content 

5.5.1 Removing Magazines 
 
You can choose to completely delete a magazine or to un-publish it. 
 

• Select iJoomla Magazine -> Manage Content -> Magazines from the menu. 
• To delete a magazine, check the box next to the magazine name and click “Delete”.  
• To un-publish a magazine, check the box next to the magazine name and click “Un-

publish” or click the “Publish” button next to the magazine’s name. 

5.5.2 Removing Issues 
 
You can choose to completely delete an issue or to un-publish it. 
  

• Select iJoomla Magazine -> Manage Content -> Issues from the menu. 
• To delete an issue, check the box next to the issue name and click “Delete”. 



• To un-publish an issue, check the box next to the issue name and click “Un-publish” or 
click the publish button next to the issue’s name. 

5.5.3 Removing Articles 
 
You can choose to completely delete an article or to un-publish it. 
 

• Select iJoomla Magazine -> Manage Content -> Articles from the menu. 
• To delete an article, check the box next to the article name and click “Delete”. 
• To un-publish an article, open the article and click “No” next to “published” on the 

publishing tab. The tab is located on the right. 
 
 
6. Modules 
 
iJoomla Magazine comes with seven unique modules that make it easy for you to organize your 
magazine and make it an even better read for your users: 
 
6.1 What are modules? 
 
Modules are the content usually appearing on either side of the component content area. They 
extend the capabilities of Joomla giving the software new functionality. 
 
6.2 Available modules 

6.2.1 Magazines Module 
 
The Magazines module displays a list of all the published magazines and can be used to allow 
your visitors to navigate between your magazines. 
 
Adding the Magazine module to your site: 
 

• Select Modules -> Site modules from the Joomla top menu. 
• Find and open the Magazine module. Choose the position of the module. 
• Select “Yes” next to the “Published” button and Save. 

 

 

6.2.2 Issues Module 
 
The Issues module displays all of the issues for the magazine currently in view. For example, if 
you are looking at magazine #1, the module will show the issues for magazine #1.  
 
Use the issues module to give your readers access to previously published issues of this 
magazine. If you’re using the issues module to create sections and home pages, you can also 
use the module to link to different sections of your site. 
 
Adding the Issues module: 



 
• Select Modules -> Site modules from the Joomla top menu. 
• Find and open the Issues module. Choose the position of the module. 
• Select “Yes” next to the “Published” button and Save. 

 
The module will be displayed in the position you've selected. A link to all published issues will be 
displayed. 
 

 
 
Tip: if you want to show only previous issues, un-publish all Upcoming Articles. If you do not wish 
to show the default issue, select “No” on the drop down menu next to “Don't display default 
issue.” 

6.2.3 Featured Article 
 
The Featured Article module will display the featured article for the issue currently being viewed. 
So if you are looking at issue #1, the module will show the featured article for issue #1; if you’re 
looking at issue #3, it will show the featured article chosen for issue #3 
 
If you are viewing a page that is not a magazine page, this module will display the featured article 
of the default issue of the default magazine. 
 
Adding the Featured Articles module: 
 

• Select Modules -> Site modules from the Joomla top menu. 
• Find and open the Featured Article module. Choose the position of the module. 
• Select “Yes” next to the “Published” button and Save. 

 



 

6.2.4 Upcoming Articles Module 
 
The Upcoming Article module displays the titles of articles to be published in the next issue of this 
magazine and gives your visitors an idea of what's coming up next.  
 
Note: If you don’t have a next issue available, or if you’re viewing a non-magazine page, the 
module will show “No articles available.” To prevent this from happening, you may choose to 
show the article list from an issue of your choice. Just enter the issue ID next to the text box that 
says “Show this issue if no Upcoming Article is available (Enter Issue ID)”. 
 
Adding the Upcoming Article module: 
 

• Select Modules -> Site modules from the Joomla top menu. 
• Find and open the Upcoming Articles module. Choose the position of the module. 
• Select “Yes” next to the “Published” button and Save. 

 



 

6.2.5 Current Articles 
 
The Current Article module displays all the articles in the default issue of the magazine currently 
in view. Place this module in a strategic location on your site to give your visitors easy access to 
your articles. The module will display the current articles of the default issue of the default 
magazine on non-magazine pages. 
 
To add the Current Articles module: 
 

• Select Modules -> Site modules from the Joomla top menu. 
• Find and open the Upcoming Articles module. Choose the position of the module. 
• Select “Yes” next to the “Published” button and Save. 

 

 

6.2.6 Author list 
 
This module displays a list of your authors. Authors are all the members who have publishing 
rights on your site. Each author name on the list links to their profile. The profiles include: name, 
photo, full bio, link to their website and email. 
 
Groups on the list include: authors, editors, publishers, managers, administrators and super 
administrator. 



 
 
Use this module to allow your visitors to learn more about contributors to your site. 
 
Adding the Author List module: 
 

• Select Modules -> Site modules from the Joomla top menu. 
• Find and open the Author List module. Choose the position of the module. 
• Select “Yes” next to the “Published” button and Save. 

 
 
7. Plugin (Mambot) – Extra Article Features 
 
Note: Please make sure the plugin is published before you begin! 
 

• Select Site ->Mambots from the Joomla top menu. 
• Check the radio button next to mos_magazine. 
• Click Publish. 

 
The iJoomla mambot allows you to complete the following tasks: 
 

1.   Display a sidebar with content from another article; 
2. Display quotes on article pages; 
3. Display a mini profile of the author of this article at the bottom; 
4. Display the “Related Articles” at the bottom of the articles; 
5. Display the “More articles by this author” at the bottom of the articles. 

 
Note: The plugin must be installed and published in order for all the above features to work. 
Please be sure to publish it after you install it! 
 



 
 
7.1 What is a plugin? 
 
A plugin is a small, task-oriented function that intercepts content before it is displayed and 
manipulates it in some way (e.g. HTML editors.) 
 
7.2 Quotes 
 
Adding quotes is super easy and allows your users to understand the content of the article with 
just a glance. Our professionally designed quote boxes give your articles that special touch. 

7.2.1 What are quotes? 
 
Quotes are a small piece of your copy that you’d like to emphasis on your article page.  

7.2.2 Adding quotes to your article page 
 
You can add as many quotes as you wish on each page. We recommend one to two quotes for 
short articles and more for longer articles. 
 

• Select iJoomla Magazine -> Manage Content -> Articles from the menu. 
• Under the column marked "Article Title", find and open the content item you'd like to edit. 



• Choose the text you’d like to quote and enter a {quotes} tag in the beginning and a 
{/quotes} tag at the end.  

• Save the page, check the result and tweak as needed. 
 
For example, from the text...: 
 
“iJoomla Magazine is feature-rich. Use it to create a real, professional-looking magazine and give 
your site the competitive edge you need. When you use iJoomla Magazine to display your 
content, you can do all of these vital tasks in just minutes:” 
 
...you might want to create a quote using this sentence: 
 
“Use it to create a real, professional-looking magazine and give your site the competitive edge 
you need” 
 
To create the quote, add the quote tags {quotes} {/quotes}around the text: 
 
“iJoomla Magazine is feature-rich. {quotes} Use it to create a real, professional-looking magazine 
and give your site the competitive edge you need {/quotes}. When you use iJoomla Magazine to 
display your content, you can do all of these vital tasks in just minutes:” 
 
This will display the quotes in an approximate location to the source text. 
 
Note: Quotes work only in full text — don’t add them to your intro text! 
 

 

7.2.3 Quote options 
 
Quotes align to the left by default but If you’d like to align the quote box to the right, add 
align=right to the opening tag: {quotes align=right}. The closing tag should remain the same. 
 

 
 
7.3 Sidebar 
 
Placing a sidebar on your article gives your magazine an extra touch and a truly professional 
look. 
 
As always, iJoomla Magazine allows you to use your existing content item to create the sidebar. 
The intro text of the article you choose will be displayed in the sidebar area. 



7.3.1 What is a sidebar? 
 
A sidebar is a block of copy, often boxed, that gives a unique or different perspective on the 
feature article it accompanies. 

7.3.2 Adding a side bar 
 
Adding a sidebar is very easy.  
 

• Select iJoomla Magazine -> Manage Content -> Articles from the menu. 
• Choose the article to which you’d like to add the sidebar.  
• Choose the sidebar tab. 
• Choose the source of the sidebar article: section, category or article. 
• Add a heading 
• Choose to show or to hide the article title 
• Choose the sidebar size 

 
For your convenience, once you choose the article, you will see a link to the article’s edit page. 
Click the link to open the article in a new window. Edit as needed and save. 
 

 

7.3.4 Sidebar Usage 
 
In the print world, sidebars are used to tell a related story or enhance the article. On the Internet, 
the sky’s the limit! 
 
Here are just a few of the ways you can use a sidebar: 

7.3.4.1 Related Story 
 
Provide additional information about the article users are currently reading. To display a related 
story, make sure the article source you choose is connected to the article to which you’re adding 
the sidebar. 

7.3.4.2 Teaser 
 



Offer a teaser for another article or more content for your users. Make sure you choose an article 
you’d like to promote. 

7.3.4.3 Google Ads/Banner 
 
To use the sidebar to display Google Ads or banners, you must first add a content item. 
 

• Select All Content Items from the Content menu. 
• Click New to start a new content item. 
• Switch the mode of your HTML editor to HTML. 
• Paste the code. 
• Save. 
• Now you can use this content item as a source to your sidebar as described above. 
 

Note: Do not confuse placing AdSense or banners in the sidebar with the banner component. 
The sidebar allows you to enter one banner/ad per article and it’s not related to the banner 
component. 
 

 
 

7.3.4.4 Comments 
 
Enter your own comments about the article for extra interest! Just create a content item with your 
comments or observations and use it as your source article. 

7.3.5 Controlling the size and the style of the sidebar 
 
You can control the size of your sidebar easily by opening the sidebar tab and choosing width 
and height in pixels. By default the size is 160 px wide and 600 px high.  
 
Note: A long intro text will also increase the height. 
 
You can change the style by opening the style sheet of the parent issue of your article. Find and 
edit the area in the code that starts /* Sidebar*/. This requires some CSS knowledge. 



 
7.4 Related Articles 

7.4.1 What are related articles? 
 
Related articles are a list of articles related to the article currently in view. This list is displayed at 
the bottom of your article page. 

7.4.2 Adding related articles to article pages 
 

• Select Settings-> General from the menu. 
• Make sure the check box next to “Show Related Articles” is ticked. 
• Choose the number of related articles to display from the dropdown menu. 
• Save. 

 

 

7.4.3 Controlling which related articles to show 
 
Related articles are dependent on the keywords of your content items. Articles with similar 
keywords will be considered related to each other. You will need to add keywords to the metatags 
of your content items. The iJoomla Metatag Generator allows you to do that fast. Click here for 
more information. 

7.4.4 Hiding related articles 
 

• Select iJoomla Magazine ->  Settings-> General from the menu. 
• Un-check the box next to “Show Related Articles”. 
• Save. 

 

http://www.ijoomla.com/MetaTag_Generator/iJoomla_Metatag_Generator/iJoomla_Metatag_Generator/


 
 
7.5 More Articles by this Author 

7.5.1 What are More articles by this author 
 
An author is a user on your site who has permission to submit content. The “More articles by this 
author” feature displays a list of articles by the author of the article currently in view. You can 
choose the number articles to display. A link to the full list of articles by this author can be found 
under the article list.  

7.5.2 Adding More Articles by this author to the article pages 
 

• Select iJoomla Magazine ->  Settings-> General from the menu. 
• Make sure the check box next to “More Articles By This Author” is checked. 
• Choose the number of articles you’d like to display from the drop down menu. 
• Save. 

 



 

 

7.5.3 Hiding More articles by this author on the article page 
 

• Select iJoomla Magazine ->  Settings-> General from the menu. 
• Un-check the box next to “More Articles By This Author”. 
• Save. 

 
 
7.6 Author Mini Profile 

7.6.1 What is an Author Mini Profile? 
 
The Author Mini Profile is an area with information about the author of the article. The area 
contains four  elements: 
 

1. Mini bio 
2. Photo 
3. Name 
4. Link to full profile 

 
 



 

7.6.2 Creating an Author Mini Profile 
 

• Select iJoomla Magazine ->  Authors from the menu. 
• Click on the author’s name. 
• On the general tab, make sure the check box next to “Show Mini Profile On Article Page:” 

is checked. 
• To add a photo, click on the photo tab. To add a bio, click on the bio tab. 
• Save. 

 



 

 

 
 



 

7.6.3 Adding an Author Mini Profile 
 
The author mini profile is displayed on the profile page by default. If it’s not, you need to do the 
following: 
 

• Select iJoomla Magazine ->  Authors from the menu. 
• On the General tab check the box next to “Show Mini Profile On Article Page.” 
• Save. 

7.6.4 Hiding Author Mini Profile 
 
You can choose to hide the mini profile of selected authors.  
 

• Select iJoomla Magazine ->  Authors from the menu. 
• On the General tab un-check the box next to “Show Mini Profile On Article Page.” 
• Save. 

 



 

7.6.5 Controlling the style of the Author Mini Profile 
 
You can change the style of the Author Mini Profile by opening the style sheet of your article’s 
parent issue. Find and edit the area in the code that starts /* Author Mini Profile*/. This requires 
some CSS knowledge. 
 
 
8. Design 
 
8.1 Layouts 

8.1.1 What are layouts 
 
Layouts define how different elements are displayed on an issue page. Each magazine issue 
creates its own home page. You can choose the layout and the number of vertical and horizontal 
articles for each issue . iJoomla Magazine provides a choice of 12 possible home page layouts. 
 
All layouts have the same five elements: 
 

• Magazine name and description;  
• Issue name and description; 
• Main image; 
• Vertical articles (including a zone heading); 



• Horizontal articles (including a zone heading). 
 
You can choose to show or hide each of these elements. 
 
The magazine name and description will always be displayed on top. Remaining elements are 
placed in different locations on each layout. 

8.1.2 How to assign a layout to an issue 
 

1. Select iJoomla Magazine ->  Manage Content -> Issues from the menu. 
2. Click on the name of the issue to open it. 
3. Select the Switch to Design tab. 
Choose a layout from the drop down menu. 

 

 

8.1.3 Editing and adding new layouts 
 
Editing and adding new layouts require an advanced HTML and CSS knowledge. Please don’t 
attempt to use this feature if you do not have this knowledge.  

8.1.3.1 Editing existing layouts 
 

• Select iJoomla Magazine ->  Design -> Layout Manager from the menu. 
• Click the name of the layout to open it. 
• Make any necessary changes. 
• Save. 

8.1.3.2 Adding a new layout 
 

• Select iJoomla Magazine ->  Design -> Layout Manager from the menu. 
• Click New. 
• Enter a name for the layout. 
• Enter your HTML. 



8.1.4 Available Layouts 
 
IJoomla Magazine comes with 12 possible layouts for your issues’ home pages. You can assign a 
different layout for each issue or use the same layout each time. 
 
 

 

Layout 
# 

Description Column number suggestion 

1 Main image on top, followed by the vertical 
zone and the horizontal zone. 
 

2-4 columns for vertical items 
1-2 columns for horizontal items 

2 Main image on top left, vertical zone on the 
right and the horizontal zone under the 
main image. 
 

1-2 columns for vertical items 
1-2 columns for horizontal items 

3 Vertical zone on the top left, main image on 
the top right and the horizontal zone under 
both. 
 

1-2 columns for vertical items 
1-2 columns for horizontal items 

4 Horizontal zone on the top, main image on 
the right beneath the horizontal zone, and 
the vertical zone on the right. 
 

2-4 columns for vertical items 
1-2 columns for horizontal items 

5 Horizontal zone on the top, main image on 
the left beneath the horizontal zone and the 
vertical zone on the right. 
 

1-2 columns for vertical items 
1-2 columns for horizontal items 

6 Main image on top left, horizontal zone on 
the right and the vertical zone under the 
main image. 
 

1-2 columns for vertical items 
1-2 columns for horizontal items 

7 Main image on top, followed by the 
horizontal zone and then the vertical zone. 
 

2-4 columns for vertical items 
1-2 columns for horizontal items 

8 Main image on top left, horizontal zone on 
the right and the vertical zone under the 
main image; 
 

1-2 columns for vertical items 
1-2 columns for horizontal items 

9 Horizontal zone on the left top, the main 
image on the right and the vertical zone 
under both. 
 

1-2 columns for vertical items 
1-2 columns for horizontal items 

10 Horizontal zone on top, followed by the 
main image and the vertical zone. 
 

2-4 columns for vertical items 
1-2 columns for horizontal items 

11 Vertical zone on top above the main image 
on the left, and the horizontal zone on the 
right. 
 

1-2 columns for vertical items 
1-2 columns for horizontal items 

12 Main image on the top left, the vertical 
zone on the right and the horizontal zone 
under the main image. 
 

1-2 columns for vertical items 
1-2 columns for horizontal items 

 
Do you think you can include a diagram for these?



 
 
8.2 Styles 

8.2.1 What are Styles 
 
A style sheet defines style elements such as fonts, margins, color and spacing for a Web browser 
to use when rendering a Web page. 
iJoomla Magazine comes with 12 style sheets created by a professional CSS designer. Each 
style looks different and has a different color. Use the styles that work best with your 
template/design. 

8.2.2 How to assign a style to an issue 
 

1. Select  iJoomla Magazine ->  Manage Content -> Issues from the menu. 
2. Click on the issue name to open it. 
3. Select the Design tab. 



4. Choose a style from the drop down menu. 
 

 
 

8.2.3 Editing and adding new styles 
 

• Select iJoomla Magazine ->  Design -> Style Manager from the menu. 
• Click on the style name to open it. 
• Make any necessary changes. 
• Save. 

8.2.4 Adding a new style 
 

• Select iJoomla Magazine ->  Design -> Style Manager from the menu. 
• Click New. 
• Enter a name for your style. Note: The name has to end with .css! 
• Enter your style code. 

 
9. Magazine Newsletter 
9.1 Sending a Magazine Newsletter 

9.1.1 What is a magazine newsletter? 
 
IJoomla magazine allows you to send any of your issues to your members. They’ll receive a 
glossy magazine with all the images, articles and styles you’ve created. Clicking on any of the 
articles/images will take them directly to your site. 
 
No HTML knowledge is required to create these newsletters. 



9.1.2 Sending a Newsletter  
 

1. Select iJoomla Magazine ->  Magazine Newsletter -> Email Magazine from the menu. 
2. Choose a magazine. 
3. Choose an issue. 
4. Click on the preview link to confirm the appearance of your newsletter. 
5. Enter a subject for your newsletter. 
6. Choose a group of recipients. 
7. Click Send Mail. 

 
 

 
 
9.2 Magazine Template  
 
To access the newsletter template 
 

• Select iJoomla Magazine ->  Magazine Newsletter -> Newsletter template from the 
menu. 

 
You will see two text areas: at the top of the page you will see the HTML header of the template; 
at the bottom you can find the footer HTML of the template. 
 
These boxes are already populated by a simple header and footer. You can replace the images 
with your own and add your logo and design. 
 
The header image is located here: 
 
components/com_magazine/images/header.png 
 
The footer image is located here: 



 
components/com_magazine/images/footer.png 

9.2.1 Editing the magazine default template 
 

• Select iJoomla Magazine ->  Magazine Newsletter -> Newsletter template from the menu. 
• Open an HTML editor, such as Dreamweaver, in Code Mode. 
• Start a new document. 
• Copy and paste the content of the header box into the document. 
• Copy and paste the content of the footer box into the document. 
• In design mode make all the necessary changes such as colors, padding etc. 
• Place the cursor in the middle cell and switch to code mode.  
• Copy all the code before the cursor location and paste it into the Header box 
• Copy all the code after the cursor location and paste it into the Footer box 

9.2.2 Creating your own magazine template 
 

• Open an HTML editor such as Dreamweaver in Code Mode. 
o Start a new document (File -> New). 
o Create a table with two rows and one column. 
o On the top row, enter an image URL already located on your server. 
o Leave the second row empty. 

• Place the cursor in the middle cell and switch to code mode.  
• On iJoomla Magazine admin interface: 

o Select iJoomla Magazine ->  Magazine Newsletter -> Newsletter template from 
the menu. 

o On Dreamweaver: 
� Copy all the code before the cursor location and paste it into the Header 

box. 
� Copy all the code after the cursor location and paste it into the Footer 

box. 
o Save. 

 
 
10. Authors 
 
Creating a professional magazine also means giving credit to your authors and providing your 
readers with information about them. 
 
Our Author Manager lets you create a profile page and a mini profile including website 
information, bio and photo for all of your authors.  
 
A mini bio can be placed at the bottom of each of article linking to a full profile page that has a full 
biography, site link and contact information. 
 
10.1 Who are your authors? 
 
Members on your Joomla site can be belong to one of the following groups 
 
 

• Public Front End 
o Registered: 
o Authors 
o Editors 



o Publishers 
• Public Backend 

o Manager  
o Administrator  
o Super Administrator 

 
All the groups have permission to add content except the Registered group.  
 
10.2 View the list of authors: 
 

• Select iJoomla Magazine ->  Authors from the menu. 
 
You will now see a list of all your authors. 
 

 
 
10.3 Adding a profile to an existing author 
 

• Select iJoomla Magazine ->  Authors from the menu. 
• Click on the author’s name.  
• On the General tab: 

o Add a site URL. 
o Choose whether to show an e-mail link on the full profile. 
o Choose whether to show the Mini Profile of this author on the article pages. 
o Choose whether to show the this author on the Author Module. 

• On the Photo tab: 
o Choose an author photo. 

• On the Bio tab: 
o Add a short bio. 
o Add a full bio. 

• Save. 
 
10.4 Editing authors 
 

• Select iJoomla Magazine ->  Authors from the menu. 
• Click on the author’s name.  
• Use the three tabs to make any changes necessary. 
• Save. 

 



10.5 Adding new authors 
 

• Select iJoomla Magazine ->  Authors from the menu. 
• Click New. 
• On the General tab: 

o Add a name. 
o Add an email address. 
o Add a site URL. 
o Choose whether to show an e-mail link on the full profile. 
o Choose whether to show the Mini Profile of this author on the article pages. 
o Choose whether to show the this author on Author Module: 

• On the photo tab: 
o Choose an author photo. 

• On the Bio tab: 
o Add a short bio. 
o Add a full bio. 

• Save. 
 

Note: Adding new authors will also place them in the general user database. 
 

11.  Separators 
 

Separating the elements on your page can improve organization and enhance the look of your 
content. 
 
iJoomla allows you to choose two separators. One separator can be placed between the vertical 
articles and another can be placed between the horizontal articles. 
 
We even provide you with pre-made separators so you don’t have to design them yourself. Just 
click here to download! 
 
11.1 What are separators? 

 
Separators are very small images that are displayed repeatedly between vertical or horizontal 
items. 
 
11.2 Installing separators 

 
o  Select iJoomla Magazine ->  Settings -> Separators from the menu. 
o Adding a vertical separator: 

o Highlight the separator image on the left list and click >> to move it to the right 
list. 

o Adding a horizontal separator: 
o Highlight the separator image on the left list and click >> to move it to the right 

list. 
o Save. 

 

http://www.ijoomla.com/option,com_remository/


 
 
 

11.3 Removing separators 
 

• Select IJoomla Magazine ->  Settings -> Separators from the menu. 
• Highlight the separator image on the right list and click << to move it to the left.  

 
11.4 Creating your own separators 
 

• Open any graphic software, such as Fireworks. 
• Create a new file 3x3 px in size. 
• Paint a dot in a color of your choice for a dotted separator. Or use two dots for a dashed 

effect.  
• Export and upload to your site. 
• Test. 

 
 
12. Languages 
12.1 What is a language file? 
 
A language file contains all the word variables on the front and back end. Replacing these 
variables with other words changes them. 
 
12.2 Available languages 
 
An updated list of available languages can be found here. 
 
12.3 Editing your language file 
 

• Select iJoomla Magazine ->  Settings -> Languages from the menu. 
• Copy and paste the content of the text box into a NotePad. Make the necessary changes. 
• Copy and paste it back into the text area. 
• Save. 
 
 

Warning: Do not use word document to edit your language file! 
Messing things up is easy here and can cause serious problems. If you have never used a file 
like this before, avoid editing it. If a problem does occur, please download and re-install the 
original language file from iJoomla.com. 

http://www.ijoomla.com/option,com_remository/
http://www.ijoomla.com/option,com_remository/


 
12.4 Replacing the default language file 
 
If your language is not English, you can choose any of our language files to replace the existing 
default English file. 
 

• Visit http://www.ijoomla.com/option,com_remository/. 
• Find and download your language file. 
• Open the file and copy the content. 

 
Next, on the iJoomla Magazine interface, 
 

• Select iJoomla Magazine ->  Settings -> Languages from the menu. 
• Delete the existing content. 
• Paste the code and save. 

 
 
13.  Settings 
 
To edit the settings of iJoomla Magazine: 
 

• Select iJoomla Magazine ->  Settings from the menu. 
 
This will open four sub-menus. 
 
13.1 General Tab: 
 

1. Default Magazine – The magazine to be displayed when reaching the iJoomla magazine 
home page.  

2. Show related articles — If checked, a list of other related articles will be displayed at the 
bottom of each article. The number of articles to be displayed is determined by the drop 
down menu next to the check box.  

 
 

• Related articles are selected by matching keywords. To add related articles, 
you will need to place keywords in the article’s Metatag: 

• Select Content -> All content items and open the content item to which you’d like to 
add keywords.  

• Open the meta tab on the right and enter the keywords. 
• You can use iJoomla Metatag Generator  to help you generate keywords and 

descriptions for your content fast. 
 
3. More articles by this author – If checked, a list of articles by the author of the current 

article will be displayed at the bottom of the article. The number of articles to be displayed 
is determined by the drop down menu next to the check box. 

4. Show Powered By: if checked, a footer “powered by iJoomla magazine” will be 
displayed. 

http://www.ijoomla.com/option,com_remository/
http://www.ijoomla.com/MetaTag_Generator/iJoomla_Metatag_Generator/iJoomla_Metatag_Generator/


 
 
13.2 CSS tab  
 
 iJoomla magazine allows you full control over the style of each element of your magazine. Enter 
the name of the class (no dashes or dots are required) and use the graphics next to the areas to 
determine which class refers to each area.  
 
The style names are populated by default. You can choose to use or replace these default styles. 
Each style refers to a style that exists in the CSS files provided with iJoomla Magazine.  
 
Note: You don’t need to add styles to your template CSS file. 
 
13.3 Separators tab 
 
Choose the images to use as vertical and horizontal separators. The first image you choose will 
be used as a vertical separator and the second as the horizontal separator. If you do not specify a 
second image, a Horizontal Rule tag will be displayed instead. You may download vertical and 
horizontal articles from our FREE DOWNLOADS section:  
 
http://www.ijoomla.com/option,com_remository/
 
13.4 Language tab – This area can be used to edit the language on the back and front end. 
You may also replace the content of the language file with one of our many language file 
available at iJoomla.com. 
 
http://www.ijoomla.com/option,com_remository/
 

http://www.ijoomla.com/option,com_remository/
http://www.ijoomla.com/option,com_remository/
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